Possible Housing Problem

Discussion in 'General Discussion' started by Dougan Ironfist, Feb 19, 2013.

  1.  
    Dougan Ironfist

    Dougan Ironfist New Member

    I ran into a problem last night with housing and wanted to check and see if anyone else is running into a similar issue.

    As a GM, when I place a Marble Patio House, I enter the house and drop through the floor while walking around in it.

    Also, when I try to place a custom 2 floor house, I get the following error on the console.

    Code:
    System.IndexOutOfRangeException: Index was outside the bounds of the array.
      at Server.Multis.DesignStateDetailed..ctor(Int32 serial, Int32 revision, Int32 xMin, Int32 yMin, Int32 xMax, Int32 yMax, MultiTileEntry[] tiles)
      at Server.Multis.DesignStateDetailed.CompressionThread()
    This error appears on the console, but does not crash the server.

    For clarification, I am using a custom Map 0, but this error occurred on the standard Malas map in Luna. I do have the server pointed to its own copy of the same MUL files that the client is using. This error occurs when I try using the 7.0.3.0 SA client as well as the 7.0.29.2 classic client.

    Please let me know if anyone else is having this, or a similar, problem with player housing.

    Thank you!

    - Dougan
     
  2.  
    Dougan Ironfist

    Dougan Ironfist New Member

    Update...

    I copied back in all the standard MUL files for the 7.0.3.0 SA client. I made a separate folder copy of the MULs for OpenUO and another copy for ForkUO DataPath and got the same problem.

    Next...

    I made a separate folder copy of the MUL and UOP files for the 7.0.29.2 class client for OpenUO and another copy for ForkUO DataPath. This time, the classic marble patio worked just fine. However, when I place a custom 7x7 2 floor house, the following image is what I got.

    View attachment 395

    Something is definitely wrong here. haha
     

    Attached Files:

  3.  
    Milva

    Milva New Member

    I use 7.0.29.2 classic client. also, with ForkUo I didn't use git I downloaded the packaged one
    and updated server myself with new commits. So can't say for sure if my test server would
    be reading correct. But I placed a marble patio with no problems, both green and malas.
    Then I placed a 2 story both places with no problem. Hopefully more will join in with
    testing :)
     
  4.  
    Dougan Ironfist

    Dougan Ironfist New Member

    Thanks for the feedback Milva. Could you enlighten me on the version of Windows that you are using. Are you using Razor to connect?
     
  5.  
    Black Sheep

    Black Sheep Guest

    Have you disabled the HS format in MapDefinitions?

    Code:
    MultiComponentList.PostHSFormat = true; // OSI Client Patch 7.0.9.0
    If I'm not mistaken, custom maps and clients below 7.0.9 need this option set to false to avoid problems akin to what you're experiencing.
     
  6.  
    Dougan Ironfist

    Dougan Ironfist New Member

    No I did not. That may explain the problem with the 7.0.3.0 version. I am currently uninstalling all my clients and reinstalling just the 7.0.3.0 version for now. I'll try that if a simple reinstall isn't enough. Thanks for the tip.
     
  7.  
    Dougan Ironfist

    Dougan Ironfist New Member

    That did it. Thanks Erevan.

    Now I'm going to try to reinstall my other clients and see if I can get to working with the 7.0.29.2 classic client also.
     
    • Like Like x 2
  8.  
    Dougan Ironfist

    Dougan Ironfist New Member

    I've reinstalled the 7.0.29.2 client and everything is working perfectly now.

    Notes for anyone who has this problem in the future:
    • Running Client 7.0.3.0
      • Set MultiComponentList.PostHSFormat to false in MapDefinition.cs
    • Running Client 7.0.29.2
      • Set MultiComponentList.PostHSFormat to true in MapDefinition.cs
     
  9.  
    m309

    m309 New Member

    Ahh the joys of development. Spend hours trying to figure out a problem, uninstalling, reinstalling, pulling out hair, then find the one bool that needs set to false.

    Glad you found the issue!
     
  10.  
    Milva

    Milva New Member

    Nice glad you did get this all fixed :)